Wrong Image Is Displayed for Product

Overview

You may notice that an incorrect picture is displayed on your website for a specific product variant.

This may happen when:

  • Incorrect image was uploaded for the product 
  • A product with the same name was archived without being unpublishing first

Solution

  1. From Symphony Manage, navigate to Catalog > Products.
  2. Find the affected product and click on it.
  3. Expand the Variants/SKUs section.

    mceclip0.png

  4. Locate the affected variant and check the uploaded images.
    • If the wrong image is present there, remove it:
      1. Hover over the wrong image and click on the button to remove the faulty image.

        mceclip0.png

      2. Upload another image if needed.

        mceclip1.png

      3. Click Save in the top right corner of the page.
    • If the faulty image is not displayed on the product page, submit a ticket to Symphony Support to check if there are archived products that haven't been unpublished.
      Please specify the name and ID of the affected product and if you want our team to unpublish all archived products.

      submit.jpg


<supportagent>

  1. Connect to the database and run the following query:
    select id as ID,created as CreatedOn,title as Title,vanityUrl as URL,unlist 
    as Unpublished,archived as Archived
    from ProductCluster
    where site='<brand>' and unlist=0 and archived=1
  2. Find the product with the same name (as reported by the requester) in the list.
  3. Unpublish the archived product which is causing the issue:
    1. Open the following link replacing <brand> with the requester's brand and <Product ID> with the ID retrieved from the database:
      https://manage.symphonycommerce.com/<brand>/admin/catalog/product/simple/<Product ID>
    2. Unpublish the product.

      mceclip0.png

    3. Click Save.
  4. Confirm with the requester if all archived and published products need to be unpublished (if the user didn't specify it explicitly) and proceed to unpublish these products as well.

</supportagent>

Testing

Locate and open the affected product on your website - it should have correct images displayed.

 

Back to top

Comments

0 comments

Article is closed for comments.